From: Herbert Poetzl (herbert_at_13thfloor.at)
Date: Thu 26 Feb 2004 - 16:42:08 GMT
On Thu, Feb 26, 2004 at 04:16:08PM +0000, Mark Lawrence wrote:
> On Thu, 26 Feb 2004, Herbert Poetzl wrote:
> > adds a redundant "reboot" argument which doesn't make
> > any sense, because everybody knows that restart/halt/etc ...
> > is sent from sys_reboot() ... and if it would not be sent
> > from sys_reboot() it would also require the redundant
> > "reboot" arg to work in userspace, so what's the rationale
> > behind that?
> I've just re-read this, and realised you have not understood my mail on
> this a month ago. My proposed format was (originally s/<call>/<action>/):
> vshelper <call> <ctx> [<arg...>]
> Where <call> depends on the system call or unique area of request from
> the context. <call> would in fact *not* be "reboot" if vshelper was
> called from somewhere else in the kernel.
> If you say that <action> must be one of restart|halt|poweroff... then I
> say that the userspace helper should be called vsreboot and should not be
> used for anything other than responding to sys_reboot. Then we can
> implement another tool for any other userspace interaction.
two simple questions:
a) how would a "reboot" "poweroff" be handled differently
in userspace from a "xyz" "poweroff"?
b) wouldn't passing an environmental var, like VS_SYS
with VS_SYS="reboot" be as useful?
(this is something I suggested in the discussion with
Paul some time ago, but he said, this won't be useful
> Mark Lawrence
> Vserver mailing list
Vserver mailing list