From: Mark Lawrence (nomad_at_null.net)
Date: Thu 26 Feb 2004 - 16:16:08 GMT
On Thu, 26 Feb 2004, Herbert Poetzl wrote:
> adds a redundant "reboot" argument which doesn't make
> any sense, because everybody knows that restart/halt/etc ...
> is sent from sys_reboot() ... and if it would not be sent
> from sys_reboot() it would also require the redundant
> "reboot" arg to work in userspace, so what's the rationale
> behind that?
I've just re-read this, and realised you have not understood my mail on
this a month ago. My proposed format was (originally s/<call>/<action>/):
vshelper <call> <ctx> [<arg...>]
Where <call> depends on the system call or unique area of request from
the context. <call> would in fact *not* be "reboot" if vshelper was
called from somewhere else in the kernel.
If you say that <action> must be one of restart|halt|poweroff... then I
say that the userspace helper should be called vsreboot and should not be
used for anything other than responding to sys_reboot. Then we can
implement another tool for any other userspace interaction.
-- Mark Lawrence
_______________________________________________ Vserver mailing list Vserver_at_list.linux-vserver.org http://list.linux-vserver.org/mailman/listinfo/vserver