Re: [vserver] CVE-2016-10229: MSG_PEEK - URGENT patch needed

From: Corey Wright <undefined_at_pobox.com>
Date: Thu 18 May 2017 - 17:42:18 BST
Message-Id: <20170518114218.0cd4597302abd622ac580192@pobox.com>

On Thu, 18 May 2017 18:19:57 +0200
Romain Rivire <romain+vserver@forty-two.fr> wrote:

> Hi,
>
> On 18/05/17 17:34, Ben Green wrote:
> > Does it patch from the 3.18.44 patch OK?
>
> Yup. The 3.18.44 even applies to 3.18.52 with just a few offsets.

and patch-3.18.44-vs2.3.7.5.diff applies to 3.18.53 [1] too with no
'FAILED|fuzz' [2].

[1] which i see is finally available as a tarball/patch on kernel.org;
    i got it out of the linux-stable git repo when gkh first published
    it earlier this week

[2] except for patching the Makefile with its embedded incremented
    version number which always fails, of course

i've tested 3.18.53-vs2.3.7.5 and staged it and will reboot to it
later this week (though separate from the ubuntu kernel security
updates everywhere else; how far away are we from the "common man"
creating live kernel updates? ;).

corey

--
undefined@pobox.com
> Cheers
> -- 
> Romain
Received on Thu May 18 17:42:07 2017
[Next/Previous Months] [Main vserver Project Homepage] [Howto Subscribe/Unsubscribe] [Paul Sladen's vserver stuff]
Generated on Thu 18 May 2017 - 17:42:07 BST by hypermail 2.1.8